Director: errore del proiettore.

Di: Vittorio | 26/09/2020 17:27:46
Salve a tutti, ho creato un cd multimediale, contenente
un proiettore e 5 movie esterni con Director MX 2004.
Quando visualizzo il cd nel mio computer non dà nessun problema, quando invece vado nel pc del cliente si apre una finestra di errore con scritto;
Errore nel proiettore intro.exe
AppName:intro.exe, AppVer 10.1.0.11, ModName: im232.dill, ModVer 10.1.0.11, Offset:0000679
Sapreste dirimi come posso risolvere il problema?
p.s.
ho caricato sia gli xtras che aggiunto i vari movie al proiettore principale.

Risposte



Ciao Vittorio,
che codici e che cosa contiene il tuo file Intro?
Che piattaforma usa il tuo cliente? E quale versione?
Con che piattaforma invece hai realizzato tu il proiettore?
Hai usato il player standard per il proiettore (nel publish settings)?

Di: Pablito | 26/09/2020 17:27:46


>>Che codici e che cosa contiene il tuo file Intro?
Ho inserito gli xtras per la lettura dei video.
Ho aggiunto i movie del filmato in Publish Settings > Files > Additional Files
>>Che piattaforma usa il tuo cliente? E quale versione?
Windows Xp, non sono sicuro se home o professional
Con che piattaforma invece hai realizzato tu il proiettore?
Windows XP Professional
>>Hai usato il player standard per il proiettore (nel publish settings)?

Di: Vittorio | 26/09/2020 17:28:46


Ottimo, io direi di togliere Additional Files e rifare il proiettore esclusivamente includendo gli Xtras necessari (alternativamente inserendo nella directory del proiettore tutta la cartella Xtras) e con un bel Play Movie al primo .dir introduttivo del tuo progetto. Poi saranno i Movie stessi che richiameranno di volta in volta i file necessari.
In definitiva basterà associare al tuo primo frame del file che sarà il proiettore:
on prepareFrame me
play movie "NomeMovieSenzaEstensione"
end
Prova con tutta calma e fammi sapere poi se hai risolto.

Di: Pablito | 26/09/2020 17:28:46


OK vediamo se ho capito, ho il primo movie che è il proiettore “avvio.exe”, che richiama il primo movie del filamato e cioè intro.dir
In “avvio.dir” metto nel primo frame il seguente codice
on prepareFrame me
play movie "intro" (senza estensione)
end
poi ad un frame successivo richiamo “intro.dir” (in modo da far partire il filmato che richiama gli altri movie).
Giusto?
Non voglio approfittarne, ma potresti dirmi come si crea una cartella esterna contenente gli Xtras e che funzione devo dare al proiettore per richiamarli esternamente?
Grazie

Di: Vittorio | 26/09/2020 17:28:46


Ma scusa, se io scrivo:
>>In definitiva basterà associare al tuo primo frame del file che sarà il proiettore: ...
perché tu poi scrivi:
>>poi ad un frame successivo richiamo “intro.dir” (in modo da far partire il filmato...
Vediamo se riesco a chiarire una volta per tutte:
1. Bisogna includere sia gli Xtras che il “play movie” nel .dir vuoto che diventerà il proiettore start.exe.
2. Il filmato introduttivo intro.dir sarà richiamato proprio dal play movie “intro”.
Riguardo invece alla cartella Xtras da copiare ed incollare nella stessa cartella dove il proiettore viene eseguito, è un sistema diverso di caricare gli Xtras.
Non ne hai bisogno se incorpori gli Xtras usando la procedura:
• apri con Director il tuo file .dir che diventerà il proiettore;
• scegli la voce del menu: Modify > Movie > Xtras;
• nella finestra di dialogo Movie Xtras, clicca su Add;
• scegli lo Xtra da aggiungere al Movie;
• clicca su OK;
• ripeti la procedura per tutti gli Xtras che sono necessari per il tuo progetto.
In ogni caso, la cartella Xtras la puoi trovare dove hai installato Director.
Non devi dare alcuna istruzione per farla utilizzare dal Movie, l’importante è che sia nella stessa cartella dove il proiettore viene eseguito. Questo penso di averlo ripetuto abbastanza, fammi sapere, ciao.

Di: Pablito | 26/09/2020 17:28:46


Scusa mi potresti spiegare a cosa serve
on prepareFrame me
play movie "NomeMovieSenzaEstensione"
end
visto che inserito nel movie non succede niente.
Ti scrivo come ho strutturato il file
Ho messo in start.exe il proiettore il seguente codice:
on exitFrame
go to movie "intro.dir"
end
che richiama, appunto “intro.dir” e fa partire il filmato
comunque anche così nel mio computer non dà nessun errore
mentre nel computer del cliente si verifica il solito errore.
Sinceramente io non so come risolvere il problema.
Forese il problema è dovuto ad un bug di Macromedia Director MX 2004?

Di: Vittorio | 26/09/2020 17:28:46