Director: installare i filmati sull’hd dell'utente

Di: tigretazmania | 26/09/2020 17:19:44
Benritrovati a tutti.
Sono in fase di completamento del mio progetto in Director, tra pochissimi giorni lo dovrò consegnare e ho un problema enorme che rischia di compromettere mesi di lavoro. Ho diversi filmati QuickTime linkati e messi in una cartella allo stesso livello del proiettore. Sono ad alta qualità e quindi, per essere visualizzati correttamente, ho capito che devo per forza farli installare dall'utente sull'hard disk (da lettore dvd il trasferimento dati è troppo lento), magari potendo verificare anche, quando l'utente inserisce il disco dalla seconda volta in poi, se tale operazione è già stata fatta. Ho letto e riletto thread, provato e riprovato... ma non riesco a venirne a capo.
Per abnorme cortesia, qualcuno è in grado di aiutarmi? Se non risolvo sono ro-vi-na-to.
Grazie a go-go...

Risposte



Allora dovevi impostare il limit data rate, l’alta qualità dei video non dipende solo dal peso dei file:
http://www.001design.it/forum_italiano/thread.php?id=899
Riguardo alla copia dei file su HD invece:
http://www.001design.it/forum_italiano/thread.php?id=80

Di: Pablito | 26/09/2020 17:19:44


Grazie davvero per la solerte risposta.
Avevo in effetti già studiato i 2 thread che mi hai linkato. Riguardo alla compressione dei video - che ho calibrato a dovere - purtroppo il codec h.264, per quanto da After Effects in fase d'esportazione consenta di impostare un limite di data rate (da Premiere invece no), all'atto pratico il risultato finale è - anche a dirgli di limitarsi a 1kb/s - un data rate di più di 50mbit/s, col video che si muove come un pachiderma... e va be', usando altri codec QuickTime questo problema non sussiste; ma io mi trovo costretto a usare l'h.264, ed è soprattutto in considerazione di questo che ho deciso di di far installare tutti i filmati, circa 40, sull'hard disk dell'utente. Se non ho capito male, con la funzione CopyFile di Buddy api se ne può copiare soltanto uno. Nottetempo credo di aver risolto parzialmente il problema creando, con Inno Setup (peraltro gratuito e semplicissimo da usare), un'installazione vera e propria, il che mi va benissimo, se non fosse che tale programma è solo per piattaforma PC, mentre il mio lavoro dovrebbe rivolgersi anche agli utenti MAC. Essendo questi, indubbiamente, una minoranza (ma neanche poi tanto), potrei accontentarmi di studiare un modo, piuttosto anche un po' macchinoso, per far copiare sull'hard disk 'sti benedetti filmati via Director. E qui torno al problema originario (sempre che abbia interpretato correttamente il concetto che con Buddy api si possa copiare solo un file), e l'ansia cresce...
Grazie di nuovo a go-go...

Di: tigretazmania | 26/09/2020 17:19:44


Il baCopyFile funziona anche per più di un file.

Di: Pablito | 26/09/2020 17:19:44