Director: problemi con il testo.

Di: Cinzietta | 26/09/2020 17:55:46
Per prima cosa inizio facendo i complimenti al forum. Curiosando ho trovato un sacco di cose utili e interessanti!
Premetto che non sono molto afferrata in fatto di programmazione, lingo, ecc. Sto facendo per la tesi un cd ma ho dei problemi con il testo. Ho importato, con Director MX, il carattere (insert > media element > font…) e ho assegnato alla stringa di testo il carattere creato contrassegnato da asterisco, quando mando in esecuzione il filmato su un pc che non ha quel tipo di carattere, non riesco a vederlo con il carattere che ho usato, il “sistema” gliene assegna un altro! Sapete dirmi cosa o dove sbaglio? Sperando di essere stata chiara e non troppo lunga saluto tutto il forum ed anche chi spero che mi aiuterà! Ciao!

Risposte



Assicurati che fontXtra e fontAsset siano inclusi nel proiettore.

Di: goku | 26/09/2020 17:55:46


Ho controllato, avevo già inserito gli xtras necessari, compresi quei due! per sicurezza ho provato a rifare tutto ma il problema persiste!
Devo aver sbagliato qualcosa ma non riesco a capire cosa. Grazie! Ciao

Di: Cinzietta | 26/09/2020 17:56:46


Verifica che negli Xtras inclusi nel Movie siano presenti:
Font Asset.x32, Text Asset.x32, FontXtra.x32, TextXtra.x32
Poi controlla che nel Cast sia presente il Cast member del Font importato e che sia effettivamente applicato al tuo testo. Dopodiché pubblica un proiettore e verifica se il problema persiste.
Naturalmente, nella finestra di dialogo “Font Cast Member Properties”, (Insert > Media Element > Font...) suppongo che tu abbia selezionato l’opzione None alla voce Bitmaps e Entire Set per Characters.
Facci sapere, ciao.

Di: Pablito | 26/09/2020 17:56:46


Grazie per l'aiuto! Ma non sono ancora riuscita a verificare se funziona! Vi farò sapere! Ciao!

Di: Cinzietta | 26/09/2020 17:56:46


Purtroppo il problema persiste! sig! come ultimo tentativo vi chiedo se può servire inserire il file del font nella cartella che contiene i file di director e il proiettore, perchè ho controllato tutto quello che mi avete detto, ma quando apro il cd su un pc che non ha i font me li sostituisce con altri invece di metterci quelli che ho importato e utilizzato! Ciao!

Di: Cinzietta | 26/09/2020 17:56:46


L’unica cosa che può causare un problema di questo tipo è nei privilegi amministrativi che hai o non hai sul computer dove esegui il proiettore. Questo perché in realtà, per le versioni precedenti alla MX 2004, i font incorporati vengono provvisoriamente installati nel sistema. Tuttavia nella versione di Director MX 2004 il problema pare risolto.
Mandami il file .dir con il font già incorporato che lo controllo.

Di: Pablito | 26/09/2020 17:56:46