Director: Xtra Tabuleiro

Di: Alina | 26/09/2020 17:53:44
Ciao a tutti!
Problemino con l'Xtra Tabuleiro, se qualcuno lo conosce vi prego aiutatemi! Stiamo creando un cd rom che contiene solamente un filmato, comandato dai tasti play, avanti-veloce, indietro-veloce, pausa, ritorna all'inizio. Il problema è che quando clicco play dopo l'avanti/indietro-veloce, il filmato non si vede a velocità normale, ma velocizzato, e l'unico modo per tornare alla normalità è far ripartire il cd. Piuttosto seccante.
Tabuleiro obbliga a utilizzare behaviours già impostati per i tasti, quindi non c'è gran libertà nella programmazione...
che fare?
Grazie!

Risposte



Perchè non ti crei un set di pulsanti (immagini) e gli associ degli script creati da te?

Di: Xado | 26/09/2020 17:53:44


Perchè con Tabuleiro non è possibile, sono già impostati.

Di: Alina | 26/09/2020 17:53:44


Io ad esempio carico un filmato tramite script e poi lo controllo con 3 pulsanti PLAY, STOP e REWIND & STOP.
Gli script associati a questi pulsanti sono:
on mouseUp
videoplay(sprite 5)
end
on mouseUp
videopause(sprite 5)
end
on mouseUp
videopause(sprite 5)
videoseek(sprite 5, 0)
end
Tu potresti sul tasto di avanti-veloce/indietro-veloce differenziare mouseDown (clicchi e tieni premuto) e mouseUp(rilascio del mouse) e sul secondo scrivere:
on mouseUp
videoplay(sprite 5)
end

Di: Xado | 26/09/2020 17:53:44


Grazie, ma non funziona. Forse tu hai una versione diversa di Director, con l'8.5 non va... Certi comandi non rispondono e in più il filmato si vede "sfarfallato"...

Di: Alina | 26/09/2020 17:54:44


Io uso Director MX.

Di: Xado | 26/09/2020 17:54:44


prova con questi:
PLAY
on mouseUp me
sprite(sprite 23).movieRate = 1
end
PAUSE
on mouseUp me
sprite(sprite 23).movieRate = 0
end
FFW
on mouseDown me
sprite(23).movieRate = 4
end
on mouseUp me
sprite(23).movieRate = 1
end
REWIND
on mouseDown me
sprite(sprite 22).movieRate = -4
end
on mouseUp me
sprite(sprite 22).movieRate = 1
end
;)
ciao
zero

Di: zero | 26/09/2020 17:54:44