Dreamweaver: menu javascript e sp 2.

Di: mreds | 26/09/2020 18:20:04
Salve a tutti.
Da qualche tempo realizzo delle aree web riservate (molto semplici e spartane) dove ho delle immagini di rollover che con l'aggiornamento del sistema (win Xp) al SP2 non funzionano più (... contenuto attivo bloccato...). Ho provato a sostituirle con dei popup menu in javascript ma il risultato è identico. Ho provato ad inserire il "Mark of the Web" come consigliato sul sito della Macromedia ma l'unico risultato che ottengo è che l'odiosa barra gialla con l'avviso "contenuto attivo bloccato ..." non compare.
Che cosa sto sbagliando?
Spero di aver spiegato chiaramente il problema e ringrazio sin d'ora quanti vorranno rispondere.
Marco

Risposte



Per sboccare definitavamente le barre popup, procedi così:
apri Explorer, menu Stumenti > Opzioni internet > scheda Avazate > Protezione e spunta la casella a fianco a Consenti contenuto attivo in file del computer.
Facci sapere sei hai risolto.

Di: Gian Paolo | 26/09/2020 18:20:04


Si è vero!
Ho tralasciato questa indicazione.
La questione è: se non vedo il contenuto attivo sulle pagine che realizzo, perché lo vedo in molti altri siti (compreso questo). Mi spiego meglio: i menu realizzati con javascript di molti siti che visito (immagino anche quello della home page di 001design.it), vengono visualizzati correttamente (anche senza apri Explorer, menu Stumenti > Opzioni internet > scheda Avazate > Protezione e spunta la casella a fianco a Consenti contenuto attivo in file del computer). I miei menu niente!
Grazie ancora

Di: mreds | 26/09/2020 18:20:04


Ciao, eccoti il link per i menu a tendina utilizzando Dreamweaver.
http://www.001design.it/forum_italiano/thread.php?id=96
Alternativamente puoi usare Fireworks MX 2004 per realizzare un funzionante menu a tendina.
Prova entrambi, dovresti risolvere così il problema di compatibilità.

Di: Pablito | 26/09/2020 18:20:04


Ciao Pablito e grazie anche a te.
Purtroppo il problema non è neanche questo. Il menu con Dreamweaver lo so creare, è anche piuttosto semplice...
Il problema è vederlo funzionare senza che Explorer mostri la barra gialla "Contenuto attivo bloccato... ecc. ecc."
Se il menù di 001design.it è costruito con javascript e il mio browser lo visualizza correttamente, perché i miei menu, aperti con lo stesso browser non vengono caricati finchè non agisco sulla famigerata barra gialla?
Grazie ancora, Marco

Di: mreds | 26/09/2020 18:20:04


Già hai fatto le due prove? Sia con Fireworks che con Dreamweaver?
Chissà perché devo sempre ripetere le cose... Prova con il Javascript che esporta Fireworks.
Avresti già risolto perché il menu di 001design.it l’ho realizzato io.
Ci sono Javascript e Javascript, anche le versioni sono importanti per le compatibilità con i browser.

Di: Pablito | 26/09/2020 18:20:04


Problema risolto. Scusate se vi ho rotto...
In effetti il problema esiste solo quando si testa la pagina “in locale”. Infatti una volta pubblicato sul server il menu funziona correttamente. Erano giorni che provavo e riprovavo... ma non avevo mai pubblicato perché pensavo ci fosse un problema di altro tipo.
Ringrazio tutti per i consigli.

Di: mreds | 26/09/2020 18:20:04