Flash: cornice imposta dalla Microsoft

Di: WebmasterTV | 26/09/2020 18:38:19
Innanzitutto un saluto a tutti.
E' la prima volta che partecipo a questo forum e mi sembra il posto giusto per la risoluzione di questo problema: Molti sapranno delle modifiche apportate dalla Microsoft ai browser IE (leggere qui):http://attivissimo.blogspot.com/2006/04/siti-per-explorer-da-rifare-entro-60.html.
Ebbene, c'è qualcuno che sappia dirmi come ovviare a questo inconveniente (in pratica, si deve cliccare 2 volte su un'animazione Flash per accedervi), magari in modo abbastanza chiaro? Ho trovato alcuni siti che ne parlano, ma, onestamente, non c'ho capito granchè anche a causa del mio pessimo inglese.
Grazie.
P.s.: credo di aver fatto la dovuta ricerca prima di postare, ma senza risultati. Nel caso esista già un topic, chiedo scusa agli amministratori.

Risposte



Hola!!!!!
...la tua è una bella domanda...
già diverse volte sul forum siamo finiti sull'argomento ma è rimasta semplicemente una segnalazione di problema in quanto non se ne è capito molto e molte sono state le ipotesi sulle cause (almeno per i post sull'argomento che ho letto!)...
...trovare una soluzione a questo inconveniente sarebbe veramente una bella cosa in quanto rende veramente scomoda la fruizione di alcuni servizi offerti per non parlare poi della pessima navigabilità che si ottiene...
...ti dirò, non essendo un vero e proprio sviluppatore e non avendo necessità di mettere siti on-line (quasi tutti i lavori che faccio finiscono per esami universitari) non mi sono molto preoccupato di trovare un modo per risolvere attivamente la cosa partendo dal codice del sito stesso, ma come utilizzatore della rete devo dire che è prorpio una scocciatura...
...nel tuo post fai riferimento a siti che trattano dell'argomento (oltre a quello che già hai postato!), anche in lingua inglese, potresti gentilmente postare i link?
Non ti prometto che troveremo una soluzione, ma avendo del materiale sul quale informarsi può già essere un buon punto di partenza...
...mi spiace non essere più utile di così...

Di: alispiegate | 26/09/2020 18:39:19


Se ho capito bene, grazie al Condivisore Senior Gian Paolo, il problema è stato affrontato e risolto così: http://www.001design.it/forum_italiano/thread.php?id=3488

Di: Pablito | 26/09/2020 18:39:19


Grazie per la cortesia che mi avete usato nel rispondere al quesito. Pablito, ho letto il topic che mi hai segnalato e, purtroppo, sono indeciso se rispondere a questo o a quello (probabilmente ci penserai tu a mettere le cose a posto). Ho scaricato e installato il Dreamweaver 8.0.2 Updater (avendo io acquistato Studio 8), suggerito da Gian Paolo. In effetti all'apertura di una qualsiasi pagina in Dreamweaver che contenga un'animazione flash, chide se si vogliono convertire i tag <object> in script browser-saft. Il risultato è: nel controllo locale (F12), la 'cornice' non c'è e tutto fila liscio, ma, una volta pubblicato sul web, sparisce l'intera animazione!
Chiedo numi, se ancora avete pazienza.
Grazie.
P.s.: per alispiegate (spero tu abbia miglior fortuna di me): i link cui facevo riferimento sono http://activecontent.blogspot.com/ e http://www.actionscript.org/forums/showthread.php3?t=106913 .
Ce ne sono ancora, basta cercarli su Google o altri motori.

Di: WebmasterTV | 26/09/2020 18:40:19

Risolto!

Ho risolto l'arcano! La soluzione, come spesso accade, è sotto i nostri occhi ma non ce ne accorgiamo (almeno io non me ne sono accorto finchè non ho cliccato su '?' della finestra che si apre dopo aver scaricato Dreamweaver 8.0.2 Updater). Ho infatti appreso che bisogna trasferire sul server, anche la cartella (chiamata Scripts) e che Dreamweaver 8.0.2 Updater crea automaticamente nella cartella del sito dove è contenuto il file .html da 'trasformare'. Prima trasferivo solo il file AC_RunActiveContent, che avevo scaricato singolarmente.
Spero che questo possa essere di aiuto ad altri e ringrazio sentitamente tutti coloro che mi hanno aiutato (senza Pablito e Gian Paolo, difficilmente sarei arrivato alla soluzione in così poco tempo).
Alla prossima.

Di: WebmasterTV | 26/09/2020 18:40:19


Ciao WebmasterTV, nel penultimo post del thread http://www.001design.it/forum_italiano/thread.php?id=3488 avevo messo un link di esempio in cui spiegavo la corretta allocazione del codice javascript e un link alla directory "Script" da scaricare e da caricare poi sul server... avresti risparmiato un po' di tempo
Sono contento ugualmente per te per esserci riuscito da solo attraverso il ragionamento

Di: Gian Paolo | 26/09/2020 18:41:19


Giustissimo Gian Paolo! Come al solito sono molto distratto...
E' che l'argomento mi sembrava trattare il problema solo per le versioni precedenti a Flash 8, dunque ho trascurato di approfondirlo.
Comunque sia, grazie ancora e speriamo che molti webmaster entrino in questo forum che io reputo (professionalissimo!. D'altro canto, non se ne può più di cliccare due volte!!!

Di: WebmasterTV | 26/09/2020 18:41:19


Grazie anche a te per la fiducia e per i complimenti.
Nel caso volessi pubblicare un feedback o commento su 001design.it puoi farlo nella sezione apposita: http://www.001design.it/forum_italiano/forums.php?id=18

Di: Pablito | 26/09/2020 18:41:19

ho trovato!!!

perchè non provate ad andare a vedere su:
http://www.amarasoftware.com/flash-problem.htm
Hanno risolto in modo egregio il problema e tutti possono applicarlo senza sapere una riga di codice...basta copiare ed incollare...

Di: lukedarkside | 26/09/2020 18:41:19