Flash: problemi con attachSound

Di: elenute | 26/09/2020 18:16:14
non è possibile...mi capitano tutte a me?
devo inserire come sottofondo di un sito web una canzone in mp3 che si può accendere e spegnere con due pulsanti on e off.
ho seguito alla lettera la guida di flash su un file nuovo e mi funziona tutto. Quando invece vado ad applicare la stessa procedura nel mio sito ben che finito nn funziona niente!!!
ho fatto così. ripetiamo:
1) ho importato nella mia libreria il file musica.mp3 --> concatenamento --> nome identificatore "a_thousand_way", esporta per action script ed esporta nel primo fotogramma.
2) sul 1 fotogramma dell'intro ho creato un livello (il più basso di tutti) con scritto suono. sul primo fotogramma ho scritto il seguente script
var song_sound:Sound = new Sound();
song_sound.attachSound("a_thousand_way");
song_sound.start();
play_btn.onRelease = function() {
song_sound.start();
};
stop_btn.onRelease = function() {
song_sound.stop();
};
3) ho creato due pulsanti e ho assegnato ad ognuno nome istanza "play_btn" e "stop_btn".
ho provato il filmato e la musica nn parte.
ho provato anche questi due modi:
- in impostazione pubblicazione --> spunta a esporta audio disposiitivo--> mi da come errore “Il suono non ha un percorso per l’audio dispositivo valido benché sia stata richiesta l’esportazione dell’audio dispositivo nelle impostazioni di esportazione. Il suono verrà ignorato”
- invece lasciando vuota la casella esporta suono nn mi da errori in output ma nn funziona lo stesso....
che cosa devo fare? dove sbaglio?
Grazie a tutti
Elena

Risposte



Ciao Elenute!! anch'io ho avuto il mio bel da fare con il suono. io però ho una musica di sottofondo che viene "spenta e accesa" con un solo pulsante....se vuoi io ti mando il link alla discussione dove mi hanno spiegato per filo e per segno come fare con il suono, sempre però con un solo pulsante!!!!!!!!!
se non ti capisci chiedi pure, per quanto possa aiutarti!
http://www.001design.it/forum_italiano/thread.php?id=6160
ciao e buon lavoro!!!

Di: newflasher | 26/09/2020 18:16:14


Ciao elenute, ciao newflasher,
lo script dovrebbe funzionare, o almeno, lo script dovrebbe far partire il suono, a meno che non ci sia un errore nel nome dell’esportazione, può capitare.
Le azioni dei pulsanti le cambierei comunque, per come hai scritto tu si ottiene un pulsante Play che fa partire la musica ogni volta che lo premi, con il risultato di accavallare i suoni.
Prova anche a leggere la discussione postata da newflasher.

Di: Professore | 26/09/2020 18:16:14