Mental Ray: batch render completed... macché...

Di: iaio | 26/09/2020 18:06:47
Ragazzi sto nei casini,
faccio partire il batch render con mentalray da maya 7 (ho un mac, a titolo informativo), fa per partire, ma dopo circa un secondo mi dice:
// Result: Rendering Completed. See Console for more information. //
anche se in realtà non è per niente completo. Non parte neanche. Mi sono accertato che tra le texture non ci fosse neanche una .gif , visto che mr non le tollera ed ho messo ad off ogni filtro delle stesse. Adesso sto nelle vostre mani. Se qualcuno ha avuto lo stesso problema e conosce un modo per risolverlo gliene sarei grato davvero.
Grazie in anticipo.

Risposte



anche io ho lo stesso problema, non riesco a fare il batch render di nulla, appena partito il batch monitor si ferma li... e se provo a farne un'alto mi dice sorry, previous render not started!!
hai qualche novità?
ciao
Pietro

Di: pietro formis | 26/09/2020 18:07:47


macchè..nessuna novità!
sempre stesso problema..ma anche te hai un mac? per sapere.. e che versione? magari arriviamo ad una risposta confrontando le nostre esperienze lavorative su maya!...
ciao.

Di: iaio | 26/09/2020 18:07:47


io ho un g5 quad ma ho anche sul portatile, e su quello funziona un ibook, e la cosa me le fa girare alquanto

Di: pietro formis | 26/09/2020 18:07:47


mmm..io ho un g5 dual, ma ho un amico che anche lui ha il quad e gli gira benissimo... ma..per curosità...ti da problemi con la dinamica? così almeno vediamo se è un problema di software, magari collegato a mac con più di un processore..dato che anche a questo mio amico da problemi con la dinamica..

Di: iaio | 26/09/2020 18:07:47


non ho provato con la dinamica, ti posso dire che "render frame" funziona, batch render a volte non dice nemmeno completed, ho provato a togliere gli aggiornamenti di tiger e tornare al 10.4.2 (dato che sul portatile ho il 10.3) ma nulla da fare ho tolto tutti i file di preferenze etc... nulla... e inoltre la learning edition fa lo stesso casino... quindi non so più dove sbattere la testa...

Di: pietro formis | 26/09/2020 18:07:47


che scheda video avete tu ed il tuo amico?
io ho la gforce 7800... mah
se hai notizie mandami pure una mail, ora me ne vado a casa saluti!

Di: pietro formis | 26/09/2020 18:08:47


vedi se nel render settings hai impostato l'end frame in base a quanti frame vuoi renderizzare e poi guarda anche dove c'è scritto frame/animation ext, non deve esserci scritto tra parentesi single frame

Di: mxx | 26/09/2020 18:08:47


il problema dopo giorno e giorni e con altre scene in gioco rimane invariato... è una cosa troppo strana..mah...

Di: iaio | 26/09/2020 18:08:47


questo problema è capitato anche a me e alla fine l'ho risolto, a dir la verità non so come, ma credo che abbia cominciato a funzionare quando ho effettuato l'ottimizzazione della scena dal menu file, provate anche voi magari impostando le opzioni in modo personale. Un altra causa potrebbe essere le luci, ma queste mi hanno dato problemi solo con mental ray quando sono troppe e tutte le volte le ho collegate agli oggetti tramite il menu light linking in modo da far fare meno calcoli. Un altra causa potrebbero essere dei poligoni non manifold e nel menu dei poligoni c'è l'opzione per eliminarli. Spero di essere stato di aiuto

Di: sidious | 26/09/2020 18:08:47


grazie. ora proverò a fare come dici, anche se l'optimize scene file già l'ho provata senza risultato purtroppo..cmq provo

Di: iaio | 26/09/2020 18:09:47


allora..pare che sono riuscito a risolvere il problema per il quale il rendering con mentalray DENTRO maya si fermava dopo un tot di tempo. Avevo fatto le texture troppo grandi e a 1000 dpi per cui non credo ce la facesse a caricarle tutte. Ora il problema rimane uno solo e anche piuttosto GRANDE. in mentalray, nonostante facendo "rendering diagnostics" non mi dia alcun errore:
"MENTAL RAY RENDER DIAGNOSTICS:
0 warnings"
continua a non farmi il batch render..dandomi la solita frase di cui sopra, vale a dire:
// Result: Rendering Completed. See Console for more information. //
ma il rendering non è finito affatto!! Mamma mia come mi rode...
Vi prego aiutatemi.
ciao e grazie.

Di: iaio | 26/09/2020 18:09:47


Ho letto dei vostri problemi, non ho ben capito, il render frame lo fà e quindi non è un problema di processore(è il processore che renderizza e non la scheda video).
Io non ho un mac(ma pc), sò che maya non fà il batch render quando non settate in modo corretto cartella di destinazione e file, scrivendo questo sullo script editor.
Result: Rendering Completed. See mayaRenderLog.txt for information. Ma in realtà non ha renderizzato nessun frame.
Aprite il render settings,
Su name prefix dovete dare un nome al file
Frame/Animation name#.ext
start end frame il numero di frame che vuoi renderizzare nella timeline.
Frame Padding è l'estensioni di numero che assegnate al file(1,01,001,0001, ecc...)
Su maya file>project>set per assegnare la cartella di destinazione.E non dovreste aver nessun problema di batch. Ps Sul render settings è importante assegnare il nome al file, se lasciate la voce predefinita (not set; using filename)il batch non ve lo fa perchè non riconosce nessun tipo di nome assegnato.

Di: drittos | 26/09/2020 18:09:47


iaio novità?
Ho appena acquistato Maya complete e da quasi gli stessi problemi.
io ho chiamato Alias e lunedì? dovrei avere qualche notizia, spero, ma inizio a pensare che siua un qualche problema di sicurezza..
Su win il batch viene bloccato dal firewall, una volta disattivato tutto va perfettamente, ma sul mac anche togliendo qualsiasi restrizione sembra non andare...
inoltre ora ci sono dei fenomeni strani... rispetto alla ple, ora se lanci il batch sembra non partire ed invece anche chiudendo maya dopo un po' inizia a fare le immagini nella cartella giusta, a volte completa il lavoro, a volte si ferma alla terza o quarta (le impostazioni di rendering sono corrette) lo fa anche con scene di prova senza texture etc. ed il bello è che non lo puoi fermare! inoltre quando fai il rendering con 4 core dovrebbe renderizzare in 4 zone diverse dell'immagine... a volte capita a volte no... mah?!?!
appena ho notizie vi faccio sapere, ciao!!

Di: pietro formis | 26/09/2020 18:09:47


Pare io abbia risolto questo tipo di problema cancellando a mano ogni libreria di alias e di Maya (lavoro di un oretta) dal sistema. Ho reinstallato ed ora funge... ora bisogna vedere per quanto ancora :D
Grazie a tutti dell'aiuto.
Ciao.

Di: iaio | 26/09/2020 18:09:47


Ciao ragazzi, ho avuto anch'io questo problema e cosi l'ho risolto: start/esegui nella stringa scrivete cmd aspettate che si apre la finesta e successivamente scrivete render.
Salvate la vostra scena di Maya, fate un drag and drop dell'icona del file vicino alla parola render.
Premete invio, dovrebbe partire il batch!
Provate per credere
Ciao

Di: Mike0312 | 26/09/2020 18:10:47


anche a me dà lo stesso errore ma xche come cavolo si fa???
qualcuno mi sa aiutare??
Aiuto urgentissimo
devo fare un esame domani...su maya
ma nn me fa i rende che pizza...io ho maya 7 come faccio a vedere questo render???
grazie

Di: silvia 1 | 26/09/2020 18:10:47


ciao ragazzi anche io ho avuto questo problema
provate q rinominare la cartella di installazione di maya con maya(bak)
provare per credere
oppure
andate nella cartella maya
poi cartella 7.0 (o della vostra versione)
cartella prefs
e cancellate la cartella userPrefs.mel
ciao

Di: deniscape | 26/09/2020 18:10:47


hai controllato la dimensione totale delle immagini che utilizzi nella scena...
sarebbe buona regola utilizzare lo stretto indispensabile in termini di risoluzione
es. se il render sarà 1280x1024px la texture è inutile che abbia una risoluzione maggiore...
sarebbe buona norma non eccedere i 50 mb totali per la cartella source images

Di: Ico | 26/09/2020 18:11:47


[USER]Ico[/USER]


sarebbe buona norma non eccedere i 50 mb totali per la cartella source images

per quale motivo "sarebbe buona norma" una cosa del genere scusa? in base a cosa lo dici?
ho continuamente progetti nei quali la cartella SourceImages va ben oltre 1 o 2 Gb e, non ho mai avuto problemi di nessun tipo...
su quali argomentazioni basi questa tua frase?

Di: _nick | 26/09/2020 18:11:47