problema swf esterni e loadmovie()

Di: jamiro08 | 26/09/2020 18:56:15
ciao,
sto realizzando un sito internet in cui entrano ed escono riquadri che corrispondono alle varie sezioni del sito. i riquadri sono praticamente degli swf esterni (meta' timeline il riquadro entra, meta' timeline il riquadro esce) caricati di volta in volta in un movieclip tramite il codice riportato sotto...
il problema e' questo: non riesco a fare in modo che prima di essere caricato il nuovo swf alla pressione del tasto, l'swf caricato in precedenza "esca" dallo stage con interpolzione movimento.
ho provato con il seguente As sul pulsante:
on(release){
_root.swfesterni_mc.gotoAndPlay(10);
_root.swfesterni_mc.loadMovie("swf_gallery.swf");
}
ma quello che ottengo e' che la prima istruzione viene praticamente saltata dalla seguente.
vedo "swf_gallery.swf" che viene caricato ma non il precedente che esce (play dal frame 10).
come devo fare?
mi servirebbe un istruzione che gli impone di caricare il secondo quando il primo ha terminato i fotogrammi.
ho provato ad inserire un if in cui gli impongo di verificare che il _root.swfesterni_mc._currentframe sia uguale a 20 (l'ultimo) prima di caricare l'altro ma nisba.
altra domanda...sto provando ad usare loadmovienum per inserire i filmati su livelli diversi per gestirli meglio ma sul swf livello 0 pubblicato non compare nessun filmato....????
ciao e grazie.

Risposte



Ciao Jamiro,
visto che hai già letto la risposta qui:tehttp://www.001design.it/forum_italiano/thread.php?id=4937
mi pare che rimanesse il problema del preload...
Puoi decidere di mettere il preload all’interno del filmato principale, ma è molto più semplice inserire il preload all’interno dei filmati caricati, in questo modo puoi fare un preload diverso per ogni filmato.

Di: Professore | 26/09/2020 18:57:15


grazie professore....

Di: jamiro08 | 26/09/2020 18:57:15