sendmail php non funzionante ...

Di: Alex Cappello | 26/09/2020 18:07:21
Ciao a tutti. Ho un problema con l'invio delle mail in un sito fatto in flash. Al tasto "invia" ho associato questo script
on (press) {
if (inputName ne "" and inputEmail ne "" and inputSubject ne "" and inputMessage ne "") {
gotoAndPlay("valid");
loadVariablesNum("sendmail.php", 0, "POST");
} else {
gotoAndPlay("invalid");
}
}
Nel sendmail in php ho inserito
<?
$adminaddress = "nome@miodominio.it";
$siteaddress ="http://www.miodominio.it";
$sitename = "miodominio.it";
$date = date("m/d/Y H:i:s");
if ($REMOTE_ADDR == "") $ip = "no ip";
else $ip = getHostByAddr($REMOTE_ADDR);
IF ($action != "")
{
mail("$adminaddress","Enquiry from www.yourwebsite.com",
"ENQUIRY FROM WEBSITE EMAIL FORM
Name: $inputName
Email: $inputEmail
Subject: $inputSubject
Message: $inputMessage
------------------------------
Logged Info :
Using: $HTTP_USER_AGENT
Hostname: $ip
IP address: $REMOTE_ADDR
Date/Time: $date","FROM:$adminaddress");
mail("$vemai","Grazie per aver visitato $sitename","La vostra e-mail sara' visionata al piu' presto ,"FROM:$adminaddress");
//Non modificate qui
$sendresult = "Done!";
$send_answer = "answer=";
$send_answer .= rawurlencode($sendresult);
// echo "$send_answer";
}
?>
Non mi funziona e non capisco xè ... qualcuno mi potrebbe aiutare per favore??
Grazie a tutti...
cappalex

Risposte



Prova a dare un'occhiata qui per la parte in flash:
http://www.001design.it/forum_italiano/thread.php?id=568
http://www.001design.it/forum_italiano/thread.php?id=1876
Adesso non ho sotto mano lo script php, ma se non ricordo male c'erano solo le variabili e il comando mail per l'invio.

Di: goku | 26/09/2020 18:07:21

niente da fare ...

Goku ho provato a basarmi sui link che mi hai dato tu ma non riesco a risolvere il problema. Sul mio sito www.cappalex.it (vuoi parlare con me??) flash esegue bene l'animazione ma è come se non considerasse lo script sendmail. Ho provato anche con il sendAndLoad dello script ma non è cambiato niente.
L'ho modificato in questo modo: al pulsante invia ho associato l'as
on (press) {
if (inputName ne "" and inputEmail ne "" and inputSubject ne "" and inputMessage ne "") {
gotoAndPlay("valid");
loadVariablesNum("sendmail.php", 0, "POST");
} else {
gotoAndPlay("invalid");
}
}
Nello script sendmail php questo
<?
$adminaddress = "alex@cappalex.it";
$siteaddress ="http://www.cappalex.it";
$sitename = "miodominio.it";
$date = date("m/d/Y H:i:s");
if ($REMOTE_ADDR == "") $ip = "no ip";
else $ip = getHostByAddr($REMOTE_ADDR);
IF ($action != "")
{
mail("$adminaddress","Enquiry from www.yourwebsite.com",
"ENQUIRY FROM WEBSITE EMAIL FORM"
Name: $inputName
Email: $inputEmail
Subject: $inputSubject
Message: $inputMessage
------------------------------
Logged Info :
Using: $HTTP_USER_AGENT
Hostname: $ip
IP address: $REMOTE_ADDR
Date/Time: $date","FROM:$adminaddress");
mail("$vemai","Grazie per aver visitato $sitename","La vostra e-mail sara' visionata al piu' presto ,"FROM:$adminaddress");
$sendresult = "Done!";
$send_answer = "answer=";
$send_answer .= rawurlencode($sendresult);
// echo "$send_answer";
}
?>

Di: Alex Cappello | 26/09/2020 18:07:21